Results 1 to 3 of 3

Thread: Using url rest api from Voxeo IVR application

  1. #1
    Junior Member
    Join Date
    Jan 2012
    Posts
    1

    Using url rest api from Voxeo IVR application

    I have created a Voxeo IVR app that records a audio response from a caller, and to obtain a transcription of the audio to text, posts it to iSpeech speech recognition API using the Post url method.

    I get back an error message: result=error&code=999&message=Invalid+request


    Here are the parameters I provided for the encoded post url:

    url:http://api.ispeech.org/api/rest
    method:Post result:string
    api: (I have obtained a web app api key)
    language: en-US
    action:recognize
    freeform:3
    content-type: audio/x-wav
    audio: RecordDetaineeNumber (RECORDING_FILE)
    output:rest

    Can anyone assist me to identify my error.

  2. #2
    Junior Member
    Join Date
    Feb 2012
    Posts
    6
    You posted this a while ago and didn't get an answer, but for what it's worth, I think the problem is with the value you set for freeform. I believe that should be either 0 or 1, i.e., true or false. It would be true if you were providing an audio file of dictation for transcription. It would be false if you were providing an audio file along with a defined set of command.

    I think you intended to use 3 to define the speech recognition model as "normal speech", which is documented in the API. But there is no reference to what parameter one would use to identify the model.

  3. #3
    Administrator
    Join Date
    Mar 2011
    Posts
    230
    Quote Originally Posted by epmcl View Post
    You posted this a while ago and didn't get an answer, but for what it's worth, I think the problem is with the value you set for freeform. I believe that should be either 0 or 1, i.e., true or false.
    A value of 0 does mean freeform is disabled, while a value of '1' tells the server to use an SMS model. A complete list of values is available here: http://www.ispeech.org/api#available_models

    As to JimIngramDC's issue, the only problem I can see is the use of 'language' as a variable. The correct variable is 'locale', but even this should not cause any issues as the default value is 'en-us'.

    This thread is old, but if you provide an audio sample, I may be able to give you a more precise reason why the transaction is failing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •